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Introduction to the reference management program Zotero 

Zotero is a free reference management program that allows you to collect, organize, 
and export sources. Exporting these sources enables you to create citations and 
bibliographies. Detailed documentation on how to install and use Zotero is available 
online. 
The following introduction does not cover every feature of Zotero, but provides an 
overview of the most important commands. It begins by describing the installation of 
the program and the Zotero interface. If you want to start by importing sources into 
Zotero right away, you can begin by reviewing the sections Add a reference via 
Connector or Add a reference via Import. 

Installation 
Zotero is downloaded from a download webpage. There, you can install the Zotero 
program for various operating systems as well as the Zotero connector for various 
browsers. 
The connector allows you to automatically import sources from your browser into 
Zotero. We therefore recommend installing it. After installation, a Z-icon ( ) usually 
appears in the top-right corner of the browser. You must first click on it and confirm 
before you can start using the connector. Sometimes the connector may be hidden in 
the browser extensions. In Firefox or Chrome, extensions are represented by a puzzle 
icon ( ). It is recommended that you pin the Zotero icon to the top bar of the browser. 
Zotero is already preinstalled on Linux systems at the University Library’s computer 
stations and in the URZ computer pools (Anwendungen → Büro → Zotero). However, 
the connector for your preferred browser still needs to be installed. 

User Interface Layout 

 

The Zotero user interface consists of a header (1) and three main columns. The left 
column (2) contains an area for the folder structure (2a) and an area for tags (2b). The 

https://www.zotero.org/support
https://www.zotero.org/download/
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middle column (3) contains a menu bar (3a) and the item area (3b). The right column 
(4) contains an information area (4a) and an icon area (4b). 

Header (1) 
Settings: Under Edit → Settings, you can configure a wide range of preferences for 
Zotero and any installed plugins. 
Groups: In addition to My Library, you can create additional libraries that support 
group collaboration. A new Group Library can be created by going to File → New 
Group. After selecting New Group, you will be redirected to the online version of 
Zotero. To use the online version, you must register with Zotero. In addition to a group 
name, you must also select a group type. After creating the group, you can configure 
additional settings online and invite members to the group. If the local Zotero instance 
has been connected to the online version via synchronization, the Group Libraries will 
appear under My Library. Further information about groups can be found in the Zotero 
documentation. 
Feeds: An RSS feed from a journal or website automatically notifies you of updates 
(such as new journal articles). The corresponding URL can be found on the relevant 
website. A new feed can be added in Zotero under File → New Feed → From URL. If 
the URL is valid, the corresponding title will appear automatically after adding the URL 
(this can be changed). After clicking OK, the feed will appear under the libraries in the 
right column. Entries in a feed can be marked as read or unread and added to a 
library. 

Left column - Folder structure (2a) 
My Library: A reference is added to the middle column as an item. All items are stored 
in My Library. Your library contains predefined special folders and can be organized 
into collections. However, collections only contain links to the items. This means that 
items can be included in multiple collections without creating duplicates. This structure 
also applies to Group Libraries. 
Recently Read: This special folder contains all items whose attachments have been 
viewed most recently. 

Collections: You can create a new collection by clicking the folder plus icon ( ) in the 
top-left corner or by right-clicking on My Library. Each collection is marked with a blue 
folder icon ( ). Right-clicking on a collection allows you to create subcollections, 
rename collections, or delete them. Deleting a collection removes only the collection 
itself, not the items in My Library. However, you can delete both the collection and its 
items by selecting the option Delete Collection and Items. 
My Publications: You can publish your own publications on the Zotero platform using 
the My Publications folder. When you drag an item of your own publication into the 
folder, a wizard opens to guide you through the publishing process. You can also 
assign a license. 
Duplicate Items: The Duplicate Items folder displays duplicate entries that can be 
merged. Selecting an item in this folder automatically selects all duplicates as well. If 
you do not want a duplicate to be included, you can remove it from the selection by 
holding down the Ctrl key and clicking on the item. When merging duplicates, a 
primary version must be selected unless all metadata matches. In addition, a selection 
field ( ) next to the metadata can be used to specify the content. Items of the same 
type (item type) can also be merged outside the Duplicates folder. To do this, all 

https://www.zotero.org/user/login/
https://www.zotero.org/support/groups
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relevant items must be selected, and the Merge Items option must be selected via a 
right-click.  
Unfiled Items: All items that are not included in any collection are displayed in this 
folder.  
Trash: The wastebasket collects all items that are to be permanently deleted. The time 
limit for automatic deletion can be set in the settings (General → Miscellaneous). The 
default setting is 30 days. Items in the wastebasket can be restored by right-clicking 
and selecting the Restore to Library command. 

Left column - Tags (2b) 
The tag area displays the keywords (tags) that have been assigned to the items in a 
collection. Selecting a tag displays only the items associated with that tag. Clicking the 
selected tag again deselects it. 
For an item, you can add new tags in the right column by clicking the icon Tags ( ) 
and using the plus symbol. When importing a reference (item), keywords may be 
automatically imported as tags. These are then displayed in black (instead of blue) 
under Tags. In the tag area, you can hide or delete automatic tags by clicking the filter 
icon ( ). 
Tags can be assigned colors. To do this, you must right-click on the tag in the tag area 
and select the Assign Color option. Each color is also assigned a number. If you select 
an item and press the corresponding number, the associated tag is automatically 
added. Pressing the number again removes the tag. 
In Windows, emojis can also be used as tags, which expands the range of available 
colors. In the Tags field (the right column for an item), you can use the Windows + . 
keyboard shortcut to open the emoji selection. The emoji appears at the beginning of 
the item title, just like a color. 
Items in the middle column can be dragged onto a tag in the tag area to automatically 
assign that tag to the items. If items are dragged onto a tag while holding down the 
Shift key, the tag will be removed from all items. 
You can delete or rename tags globally by right-clicking on a tag in the tag area. 

Middle column - Menu bar (3a) 
New Item ( ): You can use this icon to create items manually. To do so, select the 
appropriate item type. This option should only be used if the connector or the standard 
import function is not working. 
Add Item(s) by Identifier ( ): This icon allows you to create items using identifiers 
(ISBN, DOI, PMID, ...). To do so, enter the corresponding identifier. Multiple identifiers 
can also be separated by commas. 
Add Attachment ( ): This icon allows you to add standalone files or attach files to 
items. To attach a file to an item, you must first select the item. You can also attach 
files to items by right-clicking on the item. Files (such as PDFs) can also be dragged 
from your computer into Zotero. If the file is a standalone PDF, a parent item can be 
created. To do this, right-click on the PDF and select the option Create Parent Item. 
You can then import the metadata of a reference either via an identifier or by entering 
it manually. 
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New Note ( ): You can use this icon to create standalone notes and item notes. Item 
notes are associated with a specific item, so you must first select an item. You can 
also add a note to an item by right-clicking on the item. Additionally, you can use the 
icon Notes ( ) in the right column. When creating a note, an editor opens in the right 
column. By clicking the three dots in the editor, you can open it in a separate window. 
In the editor, you can also assign tags and relationships. 
Quick Search: On the right side of the menu bar, there is a search bar for quick 
searches. Clicking the magnifying glass icon allows you to specify which fields to 
search. 
Advanced Search: The Advanced Search is located behind the magnifying glass next 
to the search bar. Searching is only possible within a single library. Multiple search 
criteria can be combined. This can be done either by selecting Match all (logical “and” 
operator) or Match any (logical “or” operator). Furthermore, the percent sign (%) acts 
as a wildcard. It can serve as a placeholder for any number of characters. Search 
results can also be saved. When an advanced search is saved, a corresponding 
search folder ( ) is created in the left column. Its contents are automatically updated 
when there are new hits for the saved search. By logically combining saved searches 
under Advanced Search (using Collection as search criterion), complex searches are 
possible. Although a search folder can be found under My Library, it has different 
properties than a collection. For example, items unrelated to the search cannot be 
placed in the folder. 
Search attachments: Attached PDFs and text files can be searched using Quick 
Search (search using Everything) and Advanced Search (search criterion: Attachment 
Content). For this purpose, Zotero automatically indexes the attachments. In the 
settings (Advanced → Search), you can set limits for indexing. The index status of a 
PDF or text file can also be viewed in the attachment information in the right column 
under Indexed. 

Middle column - Item area (3b) 
The header of the item area consists of various fields (Title, Creator, Attachments, ..). 
Clicking on a field allows you to sort the items in ascending or descending order by 
that field. Right-clicking on the header opens a submenu where additional fields can 
be added. Furthermore, the fields within the header can be moved using drag and 
drop. 
Items can be dragged from My Library into collections. After selecting an item, press 
the Ctrl key to highlight all collections in the right column that contain that item. To 
delete an item from a collection, either press the Delete key or right-click the item and 
select Remove Item from Collection. To permanently delete the item (including from 
My Library), use the Move Item to Trash option. 
After selecting one or more items, you can quickly generate bibliographies or citations 
in a text file or email. To do this, simply drag the selected items from Zotero into the 
corresponding program. To create a citation, hold down the Shift key while dragging. 
Alternatively, you can use Edit → Copy Bibliography (or Edit → Copy Citation). The 
citation style used is set in the settings (Export → Quick Copy). Additionally, a 
bibliography can also be created by selecting items and right-clicking on them. To do 
this, select the Create Bibliography from Items option. You can then choose the 
citation style, language, and output method. 
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Zotero includes a built-in Reader (see the figure below). Unless otherwise specified in 
the settings (General → Reader), a PDF or snapshot will open in the Reader when 
you double-click on the document. There, you can highlight, underline, or annotate 
text passages.  
The “Read Aloud” option (headphone icon ( ) in the Reader menu bar) allows you to 
have PDFs or snapshots read aloud in the Reader. Clicking the headphone icon starts 
the function. You can choose between three voice sources: Normal, Premium and 
Local. Information on quality, origin, costs and limitations can be found in the blog post 
on Zotero 9. Once the “Read Aloud” option has been activated, you can start or stop 
the reading via the corresponding dialogue box. You can also adjust the reading speed 
and the voice source, and highlight the passages being read aloud. 

 

Right column - Information area (4a) 
The information area contains detailed information about an item's metadata, 
attachments, keywords, and relationships. The various sections can be accessed via 
drop-down menus or the icons in the icon area. 

Right column – Icon area (4b) 
Info ( ): This field allows you to edit an item's metadata. To do so, click on the 
corresponding row. Any changes made to a row are saved automatically. 
Abstract ( ): This field contains, for example, the abstract of an article. 
Attachments ( ): This field contains all PDFs and screenshots associated with an 
item. You can add new attachments by clicking the plus icon. 
Notes ( ): This field contains all notes for an item. Clicking the plus icon opens the 
note editor to create a new note. 
Libraries and Collections ( ): This field shows the folder structure to which an item 
belongs. 
Tags ( ): This field contains all tags (keywords) associated with an item. You can add 
new tags by clicking the plus icon. 
Related ( ): In this field, you can specify relationships to other items or notes. 
Clicking the plus icon opens a selection window. The relationship is also automatically 
added to the information area of the selected items or notes. This field is often used to 
represent the relationship between a book and its chapters. 
Locate ( ): This icon is not related to the information area. It provides search options 
for the item via the internet. By selecting the Library Lookup option, you can search for 
the literature associated with the item in a predefined catalog. This allows you, for 

https://www.zotero.org/blog/zotero-9/
https://www.zotero.org/blog/zotero-9/
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example, to check whether the literature is available in your own library. Before this 
option can be used, a connection to the library catalog must be established in the 
settings (General → Locate). To do this, enter the library’s resolver URL in the Base 
URL field (with the resolver option Custom). The URL for the Chemnitz University 
Library is: 

https://www-fr.redi-bw.de/links/?rl_site=tuche 

Add a reference via Connector 
The fastest way to import literary sources as items is by using the Zotero connector. It 
automatically detects the document type, associated metadata, and available PDFs on 
a webpage. 
After clicking the Z-icon (top right of the browser), a document type icon appears in its 
place (see the figure below). This can be a folder ( ), a book ( ), an article ( ), a PDF 
( ), or a similar icon. Clicking the corresponding icon adds the reference to Zotero. 
The Zotero application must be open for this to work. 

 

After clicking on a folder icon, a selection window opens. There, you can select 
individual entries from a catalog or database, or individual chapters of an e-book, for 
example. 
A download window will appear when you click the document type icon or select items 
from the list (see the figure below). The download will be saved to the library or 
collection currently selected in Zotero. You can also use this window to change the 
save location or add tags. To do so, click the arrow next to the save location. Once the 
download is complete, the window will close. 

 

The quality of metadata can vary from website to website. As a result, it is possible for 
two entries for the same source to differ from each other. Using Duplicate Items, the 
entries can be combined into a single, consolidated entry. 
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In principle, every item should be checked after automatic import to ensure consistent 
citations. 

Add a reference via Import 
You can import sources into Zotero by exporting them from a database in a standard 
format (such as RIS or BibTeX). The exported file is first saved to your computer. You 
can then open and upload the file to Zotero via File → Import. For information on 
importing from other reference management programmes, please refer to the Zotero 
documentation. 
Importing via a standard format should also be used when a large number of sources 
need to be extracted from a database. The Zotero connector may reach its limits in 
such cases. 
To import sources, you can also use the icon Add Item(s) by Identifier (magic wand 
symbol), which is described in the section on the user interface layout. 

Synchronisation 
When using Zotero locally, all items and attachments are stored on the computer you 
are using. In the settings (Advanced → Files and Folders → Data Directory Location), 
you can view the default storage location or specify a custom one. 
Synchronisation allows Zotero content to be accessed simultaneously on multiple 
devices and online. A distinction is made between data syncing and file syncing. 
During data syncing, all items and notes are synchronised. The service is free of 
charge and unlimited. To set up synchronisation, enter your login details for the online 
version of Zotero in the settings (Sync → Data Syncing). This links the local version to 
the online version. This process can be repeated on as many devices as you like. 
Synchronisation takes place automatically whenever a change is made. This can be 
changed in the settings. Furthermore, manual synchronisation is possible by using the 
synchronisation icon ( ). This is located above the icon area in the right column. 
During file syncing, attachments to an item (such as PDFs or images) are 
synchronised with the online version of Zotero. To do this, you must select the option 
Sync attachment files in My Library using Zotero in the settings (Sync → File Syncing). 
However, only the first 300 MB are free of charge. Additional storage must be 
purchased. 
An alternative to file syncing via the online version of Zotero is to use WebDAV. The 
TUCcloud can be used for this purpose, as it supports WebDAV. The steps for 
synchronising with WebDAV are described below. 

1. In the settings (Sync → File Syncing), select the option Sync attachment files in 
My Library using WebDAV. Then enter the WebDAV URL, username and 
password. This information is provided by the URZ. 

2. The URL and username can be taken from the URZ. The password still needs 
to be created in the TUCcloud. Use the link provided. Go to the Devices and 
Sessions section, enter Zotero as the app name, and generate a password. 
Make a copy of the password and return to Zotero. 

3. Enter the generated password and click Verify Server. 
4. If the setup was successful, a folder named “zotero” will be created in the 

TUCcloud. Attachments will be stored online there from now on. 

https://www.zotero.org/support/moving_to_zotero
https://www.zotero.org/support/moving_to_zotero
https://www.tu-chemnitz.de/urz/storage/cloud/
https://www.tu-chemnitz.de/urz/storage/cloud/access.html#webdav
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Plugin – Better BibTeX 
Zotero can be extended using plugins. A list of plugins can be found in the Zotero 
documentation. Below, we describe the benefits of the Better BibTeX plugin. This 
plugin is particularly useful when writing a paper in LaTeX. Instructions for 
downloading and installation in Zotero are provided on the plugin website. 
In LaTeX, the references in a bibliography are imported via a bib-file. Such a file can 
be created using the export function in Zotero. After right-clicking on a library, 
collection or selection of items, you can select the export option. An export window will 
open, in which you can select the desired format and a number of properties. 
Every source entry in a bib-file contains a citation key, which establishes the link 
between the citation in the text and the entry in the bibliography. When using the 
standard BibLaTeX export in Zotero, new citation keys are assigned in the bib-file 
each time. If the bib-file needs to be replaced in LaTeX due to changes to the sources, 
the citation keys in the new bib-file may no longer match those in the citations. With 
Better BibTeX, consistent citation keys can be defined. 
Better BibTeX allows you to permanently link a library or collection in Zotero to a bib-
file in LaTeX via an automatic export. To do this, select the Better BibLaTeX format 
and the Keep updated option in the export window. A bib-file linked to Zotero is 
created. Changes to the metadata of the items are automatically applied. As the 
selected citation key usually depends on an items metadata, it changes when the 
metadata is modified. To ensure consistent use of the citation key during automatic 
export, the citation key for an item must be fixed. To do this, right-click on the item in 
Zotero and select the option Better BibTeX → Pin BibTeX key. The fixed citation key 
appears in the Extra row of the item information. 
Changes to the syntax of citation keys and specifications for automatic export can be 
made in the settings (Better BibTeX). Multiple linked bib-files can be created and 
managed in the settings. 

Integration with word processing programs 
The connection between Zotero and a word processing program (Word or LibreOffice) 
is usually established automatically when Zotero is launched on the computer for the 
first time. Zotero icons (see the figure below) are inserted into the programs, enabling 
users to insert citations and create a bibliography. In Word, the icons can be found 
under a new tab called Zotero. If the connection is not established automatically, it can 
be set up in the Zotero settings (Cite → Word Processors). 

 

Linking Zotero to a word processing program enables automatic updates. For 
example, this allows you to import changes made to items in Zotero or to change the 
citation style used throughout the entire document in one go. However, if manual 
changes are made to the references or the bibliography, or if built-in editors are used, 
this link is broken. In that case, updates are no longer possible. Manual changes 
should only be made once the document has been finalised and a backup copy has 

https://www.zotero.org/support/plugins
https://retorque.re/zotero-better-bibtex/
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been created. At this point, the Unlink Citations icon can also be used to remove the 
link between Zotero and the word processing program. The citations and the 
bibliography are converted into plain text, which can then be edited manually. 
To create a citation, place the cursor at the desired position in the text and click the 
Add/Edit Citation icon. The first time you use this feature, the document preferences 
will appear. Here, you can select the desired citation style and adjust other 
preferences. Once the settings have been confirmed, a selection window appears 
(see the figure below). The window has two views: List and Library. 

 

In the list view, you can search for citations by entering part of the title, author’s name 
or year of a source stored in Zotero. You can search for and select multiple sources in 
succession. For each search, the possible matches are displayed below the input 
field. Clicking on a match adds the source to the input field. The reference is then 
contained in a grey bubble (in the example ). To insert the references as 
citations into the document, click on the tick on the right ( ). 
Multiple references in the input field are sorted automatically. If you do not want this, 
you can reorder them within the field. You can also toggle the sorting function on and 
off by clicking on the settings icon ( ). 
By clicking on the small arrow next to the reference in the input field, you can add 
further details (such as the page number) as well as prefixes and suffixes to the 
citation. It is also possible to remove the author from the citation. HTML tags can be 
used in the prefixes and suffixes, for example to display the text in bold (<b>Text</b>). 
In addition to the list view, there is also the library view. Here, sources can be selected 
directly from Zotero’s library structure. If you select a library and then enter a search 
term in the input field, you can also search through the items. Clicking the plus icon 
next to an item adds the sources to the input field. 
Should the citation need to be modified at a later stage, this must never be done 
manually, but only via the selection window. After selecting the citation in the text, click 
the Add/Edit Citation icon. The selection window will open again and changes can be 
made. 
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To create a bibliography for the citations in the document, place the cursor at the 
desired position in the text and click the Add/Edit Bibliography icon. The bibliography 
created is linked to Zotero. Therefore, any subsequent changes to the references 
should always be made in Zotero; otherwise, the link will be lost and automatic 
updates will no longer be possible. If an item used as a reference in the bibliography is 
modified in Zotero, the changes can be transferred to the text document by clicking 
the Refresh icon. You should therefore avoid making manual changes to the 
bibliography. 
Once you have created a bibliography, you can also add sources that do not have a 
citation in the text. To do this, click the Add/Edit Bibliography icon again. A menu for 
editing the bibliography will appear. In the upper part of the window, items can be 
transferred to the bibliography. The lower part is an editor for references, the use of 
which is not recommended. If edits are made there, the connection to Zotero is lost. 
This means that updates are no longer possible. 
The citation style and other settings can be changed whilst working on the document 
by clicking the Document Preferences icon. In this menu, under Manage Styles, you 
can also search for additional citation styles via Zotero’s settings. Changing the 
citation style affects all citations and the entire bibliography within a document. 
You can import notes or annotations from Zotero into the document using the Add 
Node and Add Annotation icons. To do this, place the cursor at the desired position in 
the text. Once you have selected the relevant icon, the selection window will appear 
again. With Add Node, you can search for notes in both views as usual. However, only 
items with notes are displayed. With Add Annotation, there is only a library view and 
also only items with annotations are displayed. An annotation could, for example, be a 
highlight in a PDF via the Reader. If the highlighted PDF text is transferred to the 
document, a citation is also created. This makes it easy to incorporate direct 
quotations from a PDF. 

Related Links 
Video tutorials on Zotero from the FH Joanneum Library (German only) 
Information on Zotero from the University Library TU Hamburg (Blog posts in German 
only) 

Anja Hähle 
19.05.2026 
 
 
 

https://www.fh-joanneum.at/en/university/services/library/training-courses/video-tutorials/
https://www.tub.tuhh.de/en/publishing/reference-management/zotero/
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